Gem issue - install mime-types-data


#1

Installing mime-types-data (3.2016.0221)
Gem::InstallError: mime-types-data requires Ruby version >= 2.0.
An error occurred while installing mime-types-data (3.2016.0221), and Bundler
cannot continue.
Make sure that gem install mime-types-data -v '3.2016.0221' succeeds before
bundling.

Trying to install dradis-ce and facing the above issue. I installed mime-types -v 2.6.2 but apparently it must be that version, however since the framework is running on 1.9.3 I am not sure how to get past this.

Thanks.


#2

@mkcph this sounds like it’s a system-specific dependency issue. Have you tried searching Google/StackOverflow for any workarounds? What happens when you run gem install mime-types-data -v '3.2016.0221'?


#3

Can you confirm your Ruby interpreter (ruby -v) is 2.0 or higher? Newer versions of Rails require you to run an up-to-date version of Ruby.

HTH,
Daniel