How-To: Install Dradis-CE 3 on Ubuntu Server 16.04


#9

Hi, While I was installing got below error message. Any advice? Thank you for your time.

Bundler could not find compatible versions for gem “RedCloth”:
In snapshot (Gemfile.lock):
RedCloth (= 4.3.1)

In Gemfile:
RedCloth (= 4.3.1)

dradis-html_export (~> 3.9) was resolved to 3.10.0, which depends on
  RedCloth (~> 4.3.2)

Sincerely,
Sasi


#10

Found a solution myself. commented on below parameter. ie. "gem ‘RedCloth’, ‘4.3.1’, require: ‘redcloth’ " in /opt/dradis-ce/Gemfile

TODO: Traveling Ruby - DANGER, DANGER: this version has an issue, but it’s

the last one supported by Traveling Ruby

gem ‘RedCloth’, ‘4.2.9’, require: ‘redcloth’

#gem ‘RedCloth’, ‘4.3.1’, require: ‘redcloth’


#11

Could some comment on the above parameter change effects? Is it fine?


#12

Hi @sboddepalli thanks for reaching out with this and I’m sorry about the delay! The technical team just merged a PR that should resolve this: https://github.com/dradis/dradis-ce/pull/340. Can you give that a try and keep us posted?


#13

Thank you very much. It is now working for me.

Another question: Could you please let us know, how to configure ssl/ self signed certs for dradis in GNU/ Linux machines?


#14

@ agreenbhm, Your contribution is really appreciated. Thank you very much.


#15

I believe this was answered and resolved here: Secure Connection Failed. Wanted to leave the link here in case others come across this thread in the future!


#16

Trying to install Dradis-CE on Linux Mint 19.1, and it’s failing. Did the following:

sudo apt-get install -y git redis-server ruby ruby-dev gcc make zlib1g-dev libsqlite3-dev libmysqlclient-dev g++

cd /opt

sudo git clone […]github.com/dradis/dradis-ce

cd /opt/dradis-ce

sudo ruby bin/setup

# got a couple of “can’t find gem bundler” errors, failed

# Support said do

sudo bundle install --path /opt/dradis-ce

# it failed, Gemfile not found, but that dir does contain a Gemfile

# and Support sends me to the community forum, I guess they can’t answer me

# tried “sudo bundle install --path /opt/dradis-ce” again today, get:
Traceback (most recent call last):
2: from /usr/local/bin/bundle:23:in <main>' 1: from /usr/lib/ruby/2.5.0/rubygems.rb:308:inactivate_bin_path’
/usr/lib/ruby/2.5.0/rubygems.rb:289:in `find_spec_for_exe’: can’t find gem bundler (>= 0.a) with executable bundle (Gem::GemNotFoundException)
# same if I run it without the sudo


#17

Hi @BillDietrich, don’t worry, we’ll help you out here! I just wanted to move this to the forum so that others who run into the same error can find the debugging.

Is this the first ruby app you’re launching on your local system? There are some dependencies that we just need to get running for you. That bundle install command is assuming that you have the bundler gem installed but your output says:

can’t find gem bundler

Does the following work for you?

$ gem install bundler

#18

Yes, first time with Ruby on my system.

sudo gem install bundler

did work, said:

Successfully installed bundler-2.0.1

1 gem installed


#19

:raised_hands: Progress! Now, could you try the bundle install and bin/setup commands again? We’re basically following these instructions now: https://dradisframework.com/ce/documentation/install_git.html


#20

$ bundle install --path /opt/dradis-ce

Could not locate Gemfile

$ ls -l /opt/dradis-ce/Gemfile

-rw-r–r-- 1 root root 5794 Jan 24 10:21 /opt/dradis-ce/Gemfile


#21

@BillDietrich what directory are you in when you run the bundle install command? Try navigating into the dradis-ce folder, then run the command again:

$ cd dradis-ce/
$ bundle install

#22

$ cd /opt/dradis-ce/

/opt/dradis-ce $ bundle install

Traceback (most recent call last):

2: from /usr/local/bin/bundle:23:in `<main>'

1: from /usr/lib/ruby/2.5.0/rubygems.rb:308:in `activate_bin_path'

/usr/lib/ruby/2.5.0/rubygems.rb:289:in `find_spec_for_exe’: can’t find gem bundler (>= 0.a) with executable bundle (Gem::GemNotFoundException)

/opt/dradis-ce $


#23

Hello @BillDietrich, I think I’ve been able to reproduce your error, also in Mint 19.1:

I think we ended up with a newer version of bundler installed than the one used to generate the Gemfile.lock file in the repo, and they are not compatible.

I fixed this problem uninstalling the newer version of bundler:
cd /opt/dradis-ce
gem uninstall bundler

Then installing the same version as the Gemfile.lock in the git repo:
cd /opt/dradis-ce
gem install bundler -v 1.16.4

Note: I really had to use sudo all the time bc I did not have proper permissions set in /opt/dradis-ce


#24

$ cd /opt/dradis-ce

/opt/dradis-ce $ sudo gem uninstall bundler
[sudo] password for user1:
Gem ‘bundler’ is not installed

/opt/dradis-ce $


#25

I thought you had bundler installed: How-To: Install Dradis-CE 3 on Ubuntu Server 16.04

What about installing version 1.16.4 ?


#26

$ cd /opt/dradis-ce

/opt/dradis-ce $ sudo gem install bundler -v 1.16.4

[sudo] password for user1:
Fetching: bundler-1.16.4.gem (100%)
Successfully installed bundler-1.16.4
1 gem installed

/opt/dradis-ce $ ruby bin/setup

== Enabling default add-ons ==
== Installing dependencies ==
The git source https://github.com/dradis/dradis-calculator_cvss.git is not yet checked out. Please run bundle install before trying to start your application
Fetching https://github.com/dradis/dradis-calculator_cvss.git
There was an error while trying to write to /home/user1/.bundle/cache/git. It is likely that you need to grant write permissions for that path.

== Command [“bundle install”] failed ==
/opt/dradis-ce $


#27

Did:

sudo chmod 777 ~/.bundle

/opt/dradis-ce $ ruby bin/setup

It did a ton of fetches and installs, ending with:

Installing whenever 0.10.0
There was an error while trying to write to /opt/dradis-ce/Gemfile.lock. It is likely that you need to grant write permissions for that path.

== Command [“bundle install”] failed ==


#28

@BillDietrich it looks like you have a whole lot of file permissions to deal with? Could you resolve those as they appear and then try again?