Install problem on kali rolling


#1

I’m running an up-to-date kali-rolling. Following the install on kali and from git instructions, I’ve installed the packages required then run the following commands:

git clone https://github.com/dradis/dradis-ce.git
cd dradis-ce/
bundle install
./bin/setup

These appear to complete without issue. Then I get the following:

root@kali:~/Dradis/dradis-ce# bundle exec rails server
bundler: failed to load command: rails (/usr/local/bin/rails)
LoadError: cannot load such file – /usr/share/rubygems-integration/all/specifications/bin/rails
/usr/local/bin/rails:23:in load' /usr/local/bin/rails:23:in<top (required)>’

Ideas? I was getting an error about a missing dradis-nessus plugin, but deleting the cloned .git and then re-cloning resolved that. Now it’s just this. Help?


A few issues on Kali 2.0 Dradis 3.0.0
#2

@4obkiUr sorry about the delay, this post got hung up in moderation. Is the rails gem installed on your local system? What’s the output of $ bundle show rails?

If that doesn’t uncover the source of the problem, could you post the output from the $ bundle install and ~$ ./bin/setup` steps? We’ll get this sorted out!


#3
output follows:

root@kali:~/Dradis/dradis-ce# bundle show rails
The gem rails has been deleted. It was installed at:
/usr/share/rubygems-integration/all/gems/rails-4.2.7.1


Don't run Bundler as root. Bundler can ask for sudo if it is needed, and
installing your bundle as root will break this application for all non-root
users on this machine.
Resolving dependencies...
Using rake 11.2.2
Using RedCloth 4.3.1
Using i18n 0.7.0
Using json 1.8.2
Using minitest 5.9.0
Using thread_safe 0.3.5
Using builder 3.2.2
Using erubis 2.7.0
Using mini_portile2 2.1.0
Using pkg-config 1.1.7
Using rack 1.6.5
Using mime-types-data 3.2016.0521
Using arel 6.0.3
Using addressable 2.4.0
Using bcrypt 3.1.10
Using debug_inspector 0.0.2
Using blankslate 2.1.2.4
Using sass 3.4.21
Using fastercsv 1.5.5
Using tilt 2.0.2
Using highline 1.7.8
Using multi_json 1.12.1
Using sexp_processor 4.6.1
Using safe_yaml 1.0.4
Using temple 0.7.6
Using terminal-table 1.5.2
Using uniform_notifier 1.9.0
Using bundler 1.13.6
Using thor 0.19.1
Using byebug 8.2.1
Using cancancan 1.13.1
Using chronic 0.10.2
Using cliver 0.3.2
Using coderay 1.1.0
Using coffee-script-source 1.10.0
Using execjs 2.6.0
Using concurrent-ruby 1.0.2
Using database_cleaner 1.5.1
Using diff-lcs 1.2.5
Using differ 0.1.2
Using dradis-plugins 3.5.0
Using rubyzip 1.1.7
Using ffi 1.9.10
Using formatador 0.2.5
Using rb-fsevent 0.9.7
Using lumberjack 1.0.10
Using nenv 0.2.0
Using shellany 0.0.1
Using method_source 0.8.2
Using slop 3.6.0
Using rspec-support 3.4.1
Using image_size 1.3.1
Using kgio 2.10.0
Using libv8 3.16.14.13
Using mono_logger 1.1.0
Using mysql2 0.3.18
Using request_store 1.3.0
Using websocket-extensions 0.1.2
Using raindrops 0.15.0
Using rdoc 4.2.1
Using redis 3.2.2
Using ref 2.0.0
Using spring 1.6.2
Using sqlite3 1.3.10
Using timecop 0.8.0
Using tzinfo 1.2.2
Using nokogiri 1.6.8
Using rack-test 0.6.3
Using rack-protection 1.5.3
Using vegas 0.1.11
Using warden 1.2.4
Using mime-types 3.1
Using launchy 2.4.3
Using binding_of_caller 0.7.2
Using parslet 1.4.0
Using bootstrap-sass 2.3.2.2
Using font-awesome-sass 4.3.2.1
Using haml 4.0.7
Using ruby_parser 3.7.3
Using slim 3.0.6
Using bundler-audit 0.4.0
Using foreman 0.78.0
Using whenever 0.9.4
Using coffee-script 2.4.1
Using uglifier 2.7.2
Using sprockets 3.7.0
Using dradis-projects 3.0.0
Using rb-inotify 0.9.5
Using notiffany 0.0.8
Using pry 0.10.3
Using rspec-core 3.4.4
Using rspec-expectations 3.4.0
Using rspec-mocks 3.4.1
Using websocket-driver 0.6.4
Using unicorn 4.9.0
Using sdoc 0.4.1
Using redis-namespace 1.5.2
Using therubyracer 0.12.2
Using activesupport 4.2.7.1
Using loofah 2.0.3
Using xpath 2.0.0
Using sinatra 1.4.7
Using mail 2.6.4
Using letter_opener 1.4.1
Using ruby2ruby 2.2.0
Using listen 3.0.5
Using rspec 3.4.0
Using rails-deprecated_sanitizer 1.0.3
Using globalid 0.3.7
Using activemodel 4.2.7.1
Using bullet 5.0.0
Using jbuilder 2.4.0
Using factory_girl 4.5.0
Using shoulda-matchers 2.8.0
Using rails-html-sanitizer 1.0.3
Using capybara 2.4.4
Using resque 1.25.2
Using brakeman 3.1.4
Using guard 2.13.0
Using rerun 0.11.0
Using rails-dom-testing 1.0.7
Using activejob 4.2.7.1
Using activerecord 4.2.7.1
Using dradis-api 0.0.1 from source at `engines/dradis-api`
Using poltergeist 1.11.0
Using resque-status 0.5.0
Using guard-rspec 4.3.1
Using actionview 4.2.7.1
Using acts_as_tree 2.4.0
Using paper_trail 4.0.2
Using actionpack 4.2.7.1
Using actionmailer 4.2.7.1
Using railties 4.2.7.1
Using kaminari 0.16.1
Using sprockets-rails 3.1.1
Using simple_form 3.2.1
Using coffee-rails 4.1.1
Using factory_girl_rails 4.5.0
Using jquery-fileupload-rails 0.3.5
Using jquery-hotkeys-rails 0.7.9.1
Using jquery-rails 4.1.0
Using jquery-ui-rails 5.0.5
Using quiet_assets 1.1.0
Using rspec-rails 3.4.2
Using rails 4.2.7.1
Using sass-rails 5.0.4
Using web-console 2.2.1
Using local_time 1.0.3
Using turbolinks 2.5.3
Using rails_autolink 1.1.6
Bundle complete! 59 Gemfile dependencies, 150 gems now installed.
Use `bundle show [gemname]` to see where a bundled gem is installed.





== Cloning core Dradis add-ons at /root/Dradis/dradis-ce/.. ==
Cloning into 'dradis-calculator_cvss'...
Cloning into 'dradis-calculator_dread'...
Cloning into 'dradis-csv'...
Cloning into 'dradis-html_export'...
Cloning into 'dradis-mediawiki'...
Cloning into 'dradis-vulndb'...
Cloning into 'dradis-acunetix'...
Cloning into 'dradis-brakeman'...
Cloning into 'dradis-burp'...
Cloning into 'dradis-metasploit'...
Cloning into 'dradis-nessus'...
Cloning into 'dradis-nexpose'...
Cloning into 'dradis-nikto'...
Cloning into 'dradis-nmap'...
Cloning into 'dradis-ntospider'...
Cloning into 'dradis-openvas'...
Cloning into 'dradis-qualys'...
Cloning into 'dradis-zap'...
Cloning into 'dradis-plugins'...
Cloning into 'dradis-projects'...
== Installing dependencies ==
The Gemfile's dependencies are satisfied

== Copying sample files ==

== Preparing database ==
The file /root/Dradis/dradis-ce/config/shared does not exists or is empty.
Generating a new secret token and writing to /root/Dradis/dradis-ce/config/shared; this will invalidate the previous Rails sessions.
DEPRECATION WARNING: Sprockets method `register_engine` is deprecated.
Please register a mime type using `register_mime_type` then
use `register_compressor` or `register_transformer`.
https://github.com/rails/sprockets/blob/master/guides/extending_sprockets.md#supporting-all-versions-of-sprockets-in-processors
 (called from block (2 levels) in <class:Railtie> at /var/lib/gems/2.3.0/gems/sass-rails-5.0.4/lib/sass/rails/railtie.rb:57)
DEPRECATION WARNING: Sprockets method `register_engine` is deprecated.
Please register a mime type using `register_mime_type` then
use `register_compressor` or `register_transformer`.
https://github.com/rails/sprockets/blob/master/guides/extending_sprockets.md#supporting-all-versions-of-sprockets-in-processors
 (called from block (2 levels) in <class:Railtie> at /var/lib/gems/2.3.0/gems/sass-rails-5.0.4/lib/sass/rails/railtie.rb:58)
-- create_table("activities", {:force=>:cascade})
   -> 0.0939s
-- add_index("activities", ["created_at"], {:name=>"index_activities_on_created_at"})
   -> 0.0937s
-- add_index("activities", ["trackable_id", "trackable_type"], {:name=>"index_activities_on_trackable_id_and_trackable_type"})
   -> 0.0921s
-- create_table("categories", {:force=>:cascade})
   -> 0.0920s
-- create_table("configurations", {:force=>:cascade})
   -> 0.1007s
-- add_index("configurations", ["name"], {:name=>"index_configurations_on_name", :unique=>true})
   -> 0.1087s
-- create_table("evidence", {:force=>:cascade})
   -> 0.0920s
-- add_index("evidence", ["issue_id"], {:name=>"index_evidence_on_issue_id"})
   -> 0.1006s
-- add_index("evidence", ["node_id"], {:name=>"index_evidence_on_node_id"})
   -> 0.1004s
-- create_table("logs", {:force=>:cascade})
   -> 0.0917s
-- create_table("nodes", {:force=>:cascade})
   -> 0.1506s
-- add_index("nodes", ["parent_id"], {:name=>"index_nodes_on_parent_id"})
   -> 0.1096s
-- add_index("nodes", ["type_id"], {:name=>"index_nodes_on_type_id"})
   -> 0.0921s
-- create_table("notes", {:force=>:cascade})
   -> 0.1007s
-- add_index("notes", ["category_id"], {:name=>"index_notes_on_category_id"})
   -> 0.1088s
-- add_index("notes", ["node_id"], {:name=>"index_notes_on_node_id"})
   -> 0.0937s
-- create_table("taggings", {:force=>:cascade})
   -> 0.1006s
-- add_index("taggings", ["tag_id", "taggable_id", "taggable_type"], {:name=>"index_taggings_on_tag_id_and_taggable_id_and_taggable_type", :unique=>true})
   -> 0.0921s
-- add_index("taggings", ["tag_id"], {:name=>"index_taggings_on_tag_id"})
   -> 0.1167s
-- add_index("taggings", ["taggable_type", "taggable_id"], {:name=>"index_taggings_on_taggable_type_and_taggable_id"})
   -> 0.1087s
-- create_table("tags", {:force=>:cascade})
   -> 0.1179s
-- add_index("tags", ["name"], {:name=>"index_tags_on_name"})
   -> 0.1007s
-- add_index("tags", ["taggings_count"], {:name=>"index_tags_on_taggings_count"})
   -> 0.1005s
-- create_table("versions", {:force=>:cascade})
   -> 0.1004s
-- add_index("versions", ["item_type", "item_id"], {:name=>"index_versions_on_item_type_and_item_id"})
   -> 0.1088s
-- initialize_schema_migrations_table()
   -> 0.2178s
-- create_table("activities", {:force=>:cascade})
   -> 0.0752s
-- add_index("activities", ["created_at"], {:name=>"index_activities_on_created_at"})
   -> 0.1011s
-- add_index("activities", ["trackable_id", "trackable_type"], {:name=>"index_activities_on_trackable_id_and_trackable_type"})
   -> 0.0843s
-- create_table("categories", {:force=>:cascade})
   -> 0.0836s
-- create_table("configurations", {:force=>:cascade})
   -> 0.0922s
-- add_index("configurations", ["name"], {:name=>"index_configurations_on_name", :unique=>true})
   -> 0.1005s
-- create_table("evidence", {:force=>:cascade})
   -> 0.0922s
-- add_index("evidence", ["issue_id"], {:name=>"index_evidence_on_issue_id"})
   -> 0.1004s
-- add_index("evidence", ["node_id"], {:name=>"index_evidence_on_node_id"})
   -> 0.0939s
-- create_table("logs", {:force=>:cascade})
   -> 0.1001s
-- create_table("nodes", {:force=>:cascade})
   -> 0.1001s
-- add_index("nodes", ["parent_id"], {:name=>"index_nodes_on_parent_id"})
   -> 0.1005s
-- add_index("nodes", ["type_id"], {:name=>"index_nodes_on_type_id"})
   -> 0.1094s
-- create_table("notes", {:force=>:cascade})
   -> 0.1007s
-- add_index("notes", ["category_id"], {:name=>"index_notes_on_category_id"})
   -> 0.0922s
-- add_index("notes", ["node_id"], {:name=>"index_notes_on_node_id"})
   -> 0.1087s
-- create_table("taggings", {:force=>:cascade})
   -> 0.1005s
-- add_index("taggings", ["tag_id", "taggable_id", "taggable_type"], {:name=>"index_taggings_on_tag_id_and_taggable_id_and_taggable_type", :unique=>true})
   -> 0.1088s
-- add_index("taggings", ["tag_id"], {:name=>"index_taggings_on_tag_id"})
   -> 0.1004s
-- add_index("taggings", ["taggable_type", "taggable_id"], {:name=>"index_taggings_on_taggable_type_and_taggable_id"})
   -> 0.1084s
-- create_table("tags", {:force=>:cascade})
   -> 0.0919s
-- add_index("tags", ["name"], {:name=>"index_tags_on_name"})
   -> 0.0838s
-- add_index("tags", ["taggings_count"], {:name=>"index_tags_on_taggings_count"})
   -> 0.0922s
-- create_table("versions", {:force=>:cascade})
   -> 0.1196s
-- add_index("versions", ["item_type", "item_id"], {:name=>"index_versions_on_item_type_and_item_id"})
   -> 0.1089s
-- initialize_schema_migrations_table()
   -> 0.2095s

== Removing old logs and tempfiles ==

== Restarting application server ==

#4
gem install rails --version=4.2.7.1 --no-ri --no-rdoc

root@kali:~/Dradis/dradis-ce# bundle exec rails server
bundler: failed to load command: rails (/usr/local/bin/rails)
LoadError: cannot load such file -- /usr/share/rubygems-integration/all/specifications/bin/rails
  /usr/local/bin/rails:23:in `load'
  /usr/local/bin/rails:23:in `<top (required)>'
root@kali:~/Dradis/dradis-ce# which rails
/usr/local/bin/rails

#5

forgot to add:
root@kali:~/Dradis/dradis-ce# bundle show rails
/var/lib/gems/2.3.0/gems/rails-4.2.7.1

Thank you. :slight_smile:


#6

@4obkiUr Thanks for the update. It looks like rails is still not installed correctly:

Do the instructions here resolve the problem for you?


#7

Well… Since I know next to nothing about Ruby, not really? Do I need to learn ruby in order to be qualified to install Dradis?


#8

Looks like a lot of stuff. What do I need to update/reinstall? Ruby seems to do a lot of things on it’s own that may be mutually exclusive with apt… Is there some magic to this?

root@kali:~/Dradis/dradis-ce# dpkg -l | grep -i ruby
ii bundler 1.13.6-2 all Manage Ruby application dependencies
ii libruby2.1:amd64 2.1.5-2+deb8u1 amd64 Libraries necessary to run Ruby 2.1
ii libruby2.3:amd64 2.3.3-1 amd64 Libraries necessary to run Ruby 2.3
ii rails 2:4.2.7.1-1 all MVC ruby based framework geared for web application development (metapackage)
ii rake 10.5.0-2 all ruby make-like utility
ii ruby 1:2.3.0+4 amd64 Interpreter of object-oriented scripting language Ruby (default version)
ii ruby-actionmailer 2:4.2.7.1-1 all email composition, delivery, and receiving framework (part of Rails)
ii ruby-actionpack 2:4.2.7.1-1 all web-flow and rendering framework putting the VC in MVC (part of Rails)
ii ruby-actionview 2:4.2.7.1-1 all framework for handling view template lookup and rendering (part of Rails)
ii ruby-activejob 2:4.2.7.1-1 all job framework with pluggable queues
ii ruby-activemodel 2:4.2.7.1-1 all toolkit for building modeling frameworks (part of Rails)
ii ruby-activerecord 2:4.2.7.1-1 all object-relational mapper framework (part of Rails)
ii ruby-activesupport 2:4.2.7.1-1 all Support and utility classes used by the Rails 4.1 framework
ii ruby-addressable 2.4.0-1 all alternative URI implementation for Ruby
ii ruby-ansi 1.5.0-1 all ANSI escape codes at your fingertips
ii ruby-arel 6.0.3-2 all SQL AST manager for Ruby
ii ruby-atomic 1.1.16-2+b6 amd64 atomic reference implementation for JRuby, Rubinius, and MRI
ii ruby-binding-of-caller 0.7.2+debian1-3 all retrieve the binding of a method’s caller
ii ruby-blankslate 3.1.3-1 all Ruby library providing a class with no predefined methods
ii ruby-buftok 0.2.0-1kali1+build1 all extracts token delimited entities from a sequence of arbitrary inputs
ii ruby-builder 3.2.2-4 all Ruby library to facilitate programatic generation of XML markup
ii ruby-bundler 1.13.6-2 all Manage Ruby application dependencies (runtime)
ii ruby-byebug 5.0.0-1+b3 amd64 Ruby 2.0 fast debugger - base + CLI
ii ruby-celluloid 0.16.0-4 all actor-based concurrent object framework for ruby
ii ruby-celluloid-io 0.16.2-3 all Ruby library providing an event-driven IO system for Celluloid actors
ii ruby-coffee-rails 4.1.0-2 all Coffee Script adapter for the Rails asset pipeline
ii ruby-coffee-script 2.4.1-1 all Ruby CoffeeScript Compiler
ii ruby-coffee-script-source 1.10.0-1 all CoffeeScript Compiler - Ruby integration
ii ruby-columnize 0.9.0-1 all Ruby library to format arrays as column-aligned strings
ii ruby-concurrent 1.0.0-3 all modern concurrency tools for Ruby
ii ruby-daemons 1.1.9-2 all Ruby daemons library
ii ruby-dataobjects 0.10.16-1 all Unified interface to various databases for Ruby
ii ruby-dataobjects-mysql 0.10.16-1+b3 amd64 MySQL adapter for ruby-dataobjects
ii ruby-dataobjects-postgres 0.10.16-1+b3 amd64 PostgreSQL adapter for ruby-dataobjects
ii ruby-dataobjects-sqlite3 0.10.16-1+b3 amd64 SQLite adapter for ruby-dataobjects
ii ruby-debug-inspector 0.0.2-1.1+b3 amd64 Ruby wrapper for the MRI 2.0 debug_inspector API
ii ruby-dev:amd64 1:2.3.0+4 amd64 Header files for compiling extension modules for Ruby (default version)
ii ruby-did-you-mean 1.0.0-2 all smart error messages for Ruby > 2.3
ii ruby-diff-lcs 1.2.5-2 all McIlroy-Hunt longest common subsequence algorithm implementation
ii ruby-dm-core 1.2.1-0kali1+build1 all Object/Relational Mapper for Ruby
ii ruby-dm-do-adapter 1.2.0-0kali1+build1 all Ruby DataObjects Adapter for DataMapper
ii ruby-dm-migrations 1.2.0-0kali2+build1 all Ruby DataMapper plugin for writing and specing migrations
ii ruby-dm-serializer 1.2.2-0kali3 all DataMapper plugin for serializing Resources and Collections
ii ruby-dm-sqlite-adapter 1.2.0-0kali2+build1 all Sqlite3 Adapter for DataMapper
ii ruby-docile 1.1.5-2 all Docile keeps your Ruby DSLs tame and well-behaved
ii ruby-domain-name 0.5.20160216-2 all Domain Name manipulation library for Ruby
ii ruby-em-websocket 0.5.1-0kali2+build1 all EventMachine based WebSocket server
ii ruby-equalizer 0.0.10-1 all Ruby module to define equality, equivalence and inspection methods
ii ruby-erubis 2.7.0-3 all fast and extensible eRuby implementation which supports multi-language
ii ruby-ethon 0.9.0-1 all libcurl wrapper using ffi
ii ruby-eventmachine 1.0.7-3+b5 amd64 Ruby/EventMachine library
ii ruby-execjs 2.6.0-1 all Run JavaScript code from Ruby
ii ruby-faraday 0.9.2-3 all HTTP/REST API client library
ii ruby-ffi 1.9.10debian-1+b2 amd64 load dynamic libraries, bind functions from within ruby code
ii ruby-geoip 1.4.0-0kali2 all Search a GeoIP database for a given host or IP address
ii ruby-globalid 0.3.6-1 all reference models by URI for Ruby on Rails
ii ruby-hike 1.2.1-3 all Ruby library to find files in a set of paths
ii ruby-hitimes 1.2.1-3+b3 amd64 fast, high resolution timer for recording performance metrics
ii ruby-http 1.0.2-3 all easy-to-use client library for making http requests from Ruby
ii ruby-http-cookie 1.0.2-1 all Ruby library to handle HTTP Cookies based on RFC 6265
ii ruby-http-form-data 1.0.1+gemwatch-1 all utility-belt to build form data request bodies
ii ruby-http-parser.rb 0.6.0-3+b3 amd64 Simple callback-based HTTP request/response parser
ii ruby-httpclient 2.7.1-1 all HTTP client library for ruby
ii ruby-i18n 0.7.0-2 all I18n and localization solution for Ruby
ii ruby-jbuilder 2.3.1-1 all creation of JSON structures via a Builder-style DSL
ii ruby-jquery-rails 4.2.1-2 all jQuery for Rails 3+
ii ruby-json 2.0.1+dfsg-3 amd64 JSON library for Ruby
ii ruby-librex 0.0.68-0kali1+build1 all Ruby Exploitation Library
ii ruby-libv8 3.16.14.13-0kali1+b1 amd64 Ruby Gem encapsulating the V8 JavaScript engine
ii ruby-listen 3.0.3-3 all Ruby library listening to file modifications
ii ruby-loofah 2.0.3-2 all manipulation and transformation of HTML/XML documents and fragments
ii ruby-mail 2.6.4+dfsg1-1 all Ruby library to handle email generation, parsing and sending
ii ruby-memoizable 0.4.2-1kali1+build1 all memoize method return values
ii ruby-mime 0.4.3-3 all MIME library for Ruby
ii ruby-mime-types 2.6.1-1 all guess MIME type of files
ii ruby-mini-exiftool 2.7.6-2 all wrapper for exiftool command-line
ii ruby-minitest 5.9.0-1 all Ruby test tools supporting TDD, BDD, mocking, and benchmarking
ii ruby-mojo-magick 0.5.6-0kali3~r2u1 all Simple Ruby stateless module interface to imagemagick
ii ruby-molinillo 0.5.0-2 all generic dependency resolution algorithm
ii ruby-msfrpc-client 1.0.1-0kali1+build1 all Ruby API for the Rapid7 Metasploit Pro RPC service
ii ruby-msgpack 1.0.0-1 amd64 Ruby library for MessagePack
ii ruby-multi-json 1.11.2-3 all Ruby library to provide easy switching between different JSON backends
ii ruby-multipart-post 1.2.0-2 all multipart form post accessory for Net::HTTP
ii ruby-naught 1.0.0-1kali1+build1 all Naught is a toolkit for building Null Objects
ii ruby-net-http-digest-auth 1.4-2 all RFC 2617 Digest Access Authentication implementation
ii ruby-net-http-persistent 2.9.4-1 all Manages persistent connections using Net::HTTP
ii ruby-net-telnet 0.1.1-2 all telnet client library
ii ruby-nio4r 1.2.1-1 amd64 Ruby library providing a selector API for monitoring IO objects
ii ruby-nokogiri 1.6.8.1-1 amd64 HTML, XML, SAX, and Reader parser for Ruby
ii ruby-oj 2.17.4-1 amd64 fast JSON parser and serializer for Ruby
ii ruby-parseconfig 1.0.2-1kali1+build1 all Simple standard configuration file parser for Ruby
ii ruby-pkg-config 1.1.7-1 all pkg-config implementation for Ruby
ii ruby-polyglot 0.3.4-1 all Custom language loaders for specified file extensions
ii ruby-power-assert 0.3.0-1 all library showing values of variables and method calls in an expression
ii ruby-qr4r 0.4.0-0kali2 all QR PNG Generator for Ruby
ii ruby-rack 1.6.4-4 all modular Ruby webserver interface
ii ruby-rack-protection 1.5.3-2 all Protects against typical web attacks for Rack apps
ii ruby-rack-test 0.6.3-1 all Simple testing API built on Rack
ii ruby-rails 2:4.2.7.1-1 all MVC ruby based framework geared for web application development
ii ruby-rails-deprecated-sanitizer 1.0.3-2 all HTML sanitizer API extracted from Action View
ii ruby-rails-dom-testing 1.0.6-1 all SOM and Selector assertions for Rails applications
ii ruby-rails-html-sanitizer 1.0.3-2 all HTML sanitization for Rails applications
ii ruby-railties 2:4.2.7.1-1 all tools for creating, working with, and running Rails applications
ii ruby-rb-inotify 0.9.7-1 all A Ruby wrapper for Linux’s inotify, using FFI
ii ruby-rchardet 1.6.1-1 all Character encoding auto-detection for Ruby
ii ruby-ref 2.0.0-1 all library implements weak, soft, and strong references in Ruby
ii ruby-rqrcode 0.4.2-3 all Ruby library for encoding QRCode (2D barcodes)
ii ruby-rspec-expectations 3.5.0c3e0m0s0-1 all Behaviour Driven Development framework for Ruby - expectations
ii ruby-rspec-support 3.5.0c3e0m0s0-1 all Behaviour Driven Development framework for Ruby - support
ii ruby-ruby-progressbar 1.6.0-0kali1 all Text progress bar library for Ruby
ii ruby-rubydns 1.0.3-0kali1 all high-performance DNS server
ii ruby-sass 3.4.22-1 all powerful but elegant CSS compiler that makes CSS fun again
ii ruby-sass-rails 5.0.6-1 all Sass adapter for the Rails asset pipeline
ii ruby-sdoc 0.4.1-2 all RDoc generator to build searchable HTML documentation for Ruby code
ii ruby-simple-oauth 0.3.1-2 all Simply builds and verifies OAuth headers
ii ruby-simplecov 0.11.1-1 all code coverage for Ruby 1.9+
ii ruby-simplecov-html 0.10.0-1 all default HTML formatter for SimpleCov code coverage tool
ii ruby-sinatra 1.4.7-5 all Ruby web-development dressed in a DSL
ii ruby-snmp 1.2.0-1 all simple network management protocol bindings for ruby
ii ruby-spider 0.5.0-2 all web spidering library for Ruby
ii ruby-spring 1.3.6-2 all Rails application preloader
ii ruby-sprockets 3.7.0-1 all Rack-based asset packaging system
ii ruby-sprockets-rails 2.3.2-1 all Sprockets Rails integration (part of Rails)
ii ruby-sqlite3 1.3.11-2 amd64 SQLite3 interface for Ruby
ii ruby-term-ansicolor 1.3.0-1 all Ruby library that colors strings using ANSI escape sequences
ii ruby-terminal-table 1.6.0-0kali1 all Ruby ASCII Table Generator, simple and feature rich
ii ruby-test-unit 3.1.7-2 all unit testing framework for Ruby
ii ruby-therubyracer 0.12.2-0kali1+b1 amd64 Ruby library to embed the V8 JavaScript interpreter
ii ruby-thor 0.19.1-3 all Ruby scripting framework
ii ruby-thread-safe 0.3.5-3 all thread-safe collections and utilities for Ruby
ii ruby-tilt 2.0.1-2 all Generic interface to multiple Ruby template engines
ii ruby-timers 4.1.1-2 all pure Ruby timer collections
ii ruby-tins 1.1.0-1 all useful tools library in Ruby
ii ruby-treetop 1.6.8-1 all Ruby-based text parsing and interpretation DSL
ii ruby-turbolinks 2.5.3-2 all following links in your Rails web application faster
ii ruby-twitter 5.16.0-1 all Ruby interface to the Twitter API
ii ruby-typhoeus 1.1.0-1 all parallel HTTP library on top of ethon
ii ruby-tzinfo 1.2.2-2 all Daylight-savings aware timezone library
ii ruby-uglifier 2.7.2+dfsg-1 all Ruby wrapper for UglifyJS JavaScript compressor
ii ruby-unf 0.1.4-2 all Wrapper library to bring Unicode Normalization Form support to Ruby
ii ruby-unf-ext 0.0.7.2-2 amd64 Unicode Normalization Form support library for CRuby
ii ruby-web-console 2.2.1-2 all Ruby on Rails debugger
ii ruby-yajl 1.2.0-3+b3 amd64 Ruby interface to Yajl, a JSON stream-based parser library
ii ruby-zip 1.2.0-1 amd64 Ruby module for reading and writing zip files
ii ruby2.1 2.1.5-2+deb8u1 amd64 Interpreter of object-oriented scripting language Ruby
ii ruby2.3 2.3.3-1 amd64 Interpreter of object-oriented scripting language Ruby
ii ruby2.3-dev:amd64 2.3.3-1 amd64 Header files for compiling extension modules for the Ruby 2.3
ii rubygems-integration 1.10 all integration of Debian Ruby packages with Rubygems
ii thin 1.6.3-2+b3 amd64 fast and very simple Ruby web server


#9

I’ve reinstalled all ruby* packages. Still getting:

LoadError: cannot load such file – /usr/share/rubygems-integration/all/specifications/bin/rails
/usr/local/bin/rails:23:in load' /usr/local/bin/rails:23:in<top (required)>’