Kali 2.0 distribution missing import plug-ins


#1

Kali 2.0 seems to have moved on from whatever was to be deprecated from the installed version in 1.0. The 2.0 only has burp and nessus enabled for import.

No one has detailed this properly for us new to dradis

I learned the hard way that you need to first edit your

Gemfile.plugins file.

first I made a backup of the file
then i noticed that the syntax is looking for a directory and if it doesn’t exist it will grab a git repository
next i found this link: http://dradisframework.org/addons/
the link listed the names of the addons from there i could find the syntax of the git names… and so my file now has (added only the free tools):

WARNINGAn line below in bold began with hash-tag(#) and modified by the forum display

Upload plugins

if Dir.exists?(’…/dradis-burp’) && !ENV[‘PACKAGING’]
gem ‘dradis-burp’, path: ‘…/dradis-burp’
else
gem ‘dradis-burp’, github: ‘dradis/dradis-burp’
end
if Dir.exists?(’…/dradis-nessus’) && !ENV[‘PACKAGING’]
gem ‘dradis-nessus’, path: '…/dradis-nessus’
else
gem ‘dradis-nessus’, github: 'dradis/dradis-nessus’
end

added dradis-nmap

if Dir.exists?(’…/dradis-nmap’) && !ENV[‘PACKAGING’]
gem ‘dradis-nmap’, path: '…/dradis-nmap’
else
gem ‘dradis-nmap’, github: 'dradis/dradis-nmap’
end

added dradis-nikto

if Dir.exists?(’…/dradis-nikto’) && !ENV[‘PACKAGING’]
gem ‘dradis-nikto’, path: '…/dradis-nikto’
else
gem ‘dradis-nikto’, github: 'dradis/dradis-nikto’
end

added dradis-openvas

if Dir.exists?(’…/dradis-openvas’) && !ENV[‘PACKAGING’]
gem ‘dradis-openvas’, path: '…/dradis-openvas’
else
gem ‘dradis-openvas’, github: 'dradis/dradis-openvas’
end

added dradis-brakeman

#if Dir.exists?(’…/dradis-brakeman’) && !ENV[‘PACKAGING’]

gem ‘dradis-brakeman’, path: ‘…/’

#else

gem ‘dradis-brakeman’, github: ‘dradis-brakeman’

#end

added dradis-osvdb

#if Dir.exists?(’…/dradis-osvdb’) && !ENV[‘PACKAGING’]

gem ‘dradis-osvdb’, path: ‘…/dradis-osvdb’

#else

gem ‘dradis-osvdb’, github: ‘dradis-osvdb’

#end

added dradis-w3af

#if Dir.exists?(’…/dradis-w3af’) && !ENV[‘PACKAGING’]

gem ‘dradis-w3af’, path: ‘…/dradis-w3af’

#else

gem ‘dradis-w3af’, github: ‘dradis-w3af’

#end

added dradis-wxf

#if Dir.exists?(’…/dradis-wxf’) && !ENV[‘PACKAGING’]

gem ‘dradis-wxf’, path: ‘…/dradis-wxf’

#else

gem ‘dradis-wxf’, github: ‘dradis-wxf’

#end

Adding Metasploit for upload

#if Dir.exists?(’…/dradis-metasploit’) && !ENV[‘PACKAGING’]

gem ‘dradis-metasploit’, path: ‘…/dradis-metasploit’

#else

gem ‘dradis-metasploit’, github: ‘dradis-metasploit’

#end

Then i ran bundle install from /usr/lib/dradis

if a repo was not found I went back and commented the entire section out. Maybe they will be available in the future.

I don’t know how to restart the server so…I rebooted kali.

There is a better way to do this but this is a start for 3.0 on Kali 2.0


#2

Hi @fose28,
Did you able to find the Enable/Disable Add-ons guide during your searching? We may need to add a link to it on the add-ons page to make sure it’s easier to find. Please give the steps in that guide a test and let us know if you run into any questions when you enable the other add-ons.