I followed http://guides.dradisframework.org/install_on_macos.html
but I encounter the following problems after installing XCode
1) When I run 'rvm install 1.9.3' I get this warning:
WARNING: Please be aware that you just installed a ruby that is no longer maintained (2016-02-24), for a list of maintained rubies visit:
http : // bugs.ruby-lang.org/projects/ruby/wiki/ReleaseEngineering
Please consider upgrading to ruby-2.4.0 which will have all of the latest security patches.
2) The tutorial says that something is supposed to happen when I 'cd' into the server directory, but on my mac, nothing happens.
Whent I examine the README.md file it tells me:
This is not the Repo you are looking for!
New development is taking place in dradis/dradis-ce.
This repo contains 2007->2015 code, from Dradis v1 to v3.0.
This repo lives here for archeological purposes.
3) Running verify.sh I get recommended to 'gem install bundler', which I did. After that, running verify.sh again I get told to 'gem install sqlite3', which I also did.
Congratulations. You seem to be ready to run the Dradis Framework.
Remember that you still need to go to the server/ folder and run:
-e bundle install
bundle install says
Could not locate Gemfile
I then turned to google after which I tried running reset.sh, but I get instructions in the terminal that urge me to run 'bundle install'.
4) I then run bundle install in the server/ subdir (also found online), but this yields another error:
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
An error occurred while installing nokogiri (1.6.5), and Bundler cannot continue.
Make sure that
gem install nokogiri -v '1.6.5' succeeds before bundling.
ruby-nmap was resolved to 0.7.0, which depends on
I tried to install nokogiri with "gem install nokogiri -v '1.6.5'", which also fails.
Google tells me to add parameters to make this work on MacOSX Sierra:
gem install nokogiri -- --with-xml2-include=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/usr/include/libxml2 --use-system-libraries
But that tells me that I need a higher version of ruby:
Fetching: mini_portile2-2.2.0.gem (100%)
Successfully installed mini_portile2-2.2.0
Fetching: nokogiri-1.8.0.gem (100%)
ERROR: Error installing nokogiri:
nokogiri requires Ruby version >= 2.1.0.
I'm at a loss here and am very open to any suggestions.