Web display not work


#1

Hi,

I installed dradis but the display web page not work.

With netstat -tlnp, I see redis port and dradis port to listen mode.
With tcpdump I see any traffic on redis port.
With tcpdump I see my web request (browser) to consult server:3000 page.

But in the browser I have failed connection.

nohup.output :

Starting resque worker in the background…
[2016-05-16 14:38:26] INFO WEBrick 1.3.1
[2016-05-16 14:38:26] INFO ruby 2.2.2 (2015-04-13) [x86_64-linux]
[2016-05-16 14:38:26] INFO WEBrick::HTTPServer#start: pid=5581 port=3000

netstat :

tcp6 0 0 ::1:3000 :::* LISTEN 5581/ruby
tcp 0 0 127.0.0.1:3000 0.0.0.0:* LISTEN 5581/ruby
tcp 0 0 127.0.0.1:6379 0.0.0.0:* LISTEN 5033/redis-server 1

tcpdump port 3000:

IP client > server : Flags [S], seq 1291713564, win 8192, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0
IP server > client : Flags [R.], seq 0, ack 1291713565, win 0, length 0
IP client > server : Flags [S], seq 2269785266, win 8192, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0
IP server > client :: Flags [R.], seq 0, ack 2269785267, win 0, length 0
IP client > server : Flags [S], seq 1291713564, win 8192, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0
IP server > client : Flags [R.], seq 0, ack 1, win 0, length 0
IP client > server : Flags [S], seq 2269785266, win 8192, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0
IP server > client : Flags [R.], seq 0, ack 1, win 0, length 0

telnet :

telnet IP 3000
Trying IP…
telnet: Unable to connect to remote host: Connection refused

In production.log, I have SQLite request.
In resque.log, I have :

I, [2016-05-16T14:38:25.321523 #5581] INFO – : Resque Logger Initialized
I, [2016-05-16T14:38:25.857777 #5599] INFO – : Resque Logger Initialized
I, [2016-05-16T14:38:26.714391 #5599] INFO – : Starting worker FQDN:5599:*
I, [2016-05-16T14:38:26.735768 #5599] INFO – : Running before_first_fork hooks

ps aux output :

dradis-3.1.0.rc2-linux-x86_64/lib/ruby/bin.real/ruby -rbundler/setup /dradis-3.1.0.rc2-linux-x86_64/lib/app/bin/rails server

Do you have any idea why I can’t display web page ?

Thanks


#2

Hi @trasla,

This line:

tcp        0      0 127.0.0.1:3000          0.0.0.0:*               LISTEN      5581/ruby 

Makes me think the server is binding to 127.0.0.1 meaning you can only connect to it from within the same host. If you want to bind to other network interfaces (e.g. to access from outside a VM for example), pass the -b command, for example:

bundle exec rails server -b 0.0.0.0

If using running from a Git clone. Or

./dradis-webapp -b 0.0.0.0

If using the packages.

HTH,
Daniel


Connecting to same Dradis instance for real time collaboration
Access Dradis from another system