CentOS Installation Errors

Hi.

I’m following the CentOS installation guide on a fresh install of CentOS 7.

I have followed the steps up until I need to install bundler (gem install bundler), but this is throwing a dependency error that Ruby >= 2.3.0 is required. The guide asks you to install Ruby 2.2.2 which I’ve done. Do you know how to install the correct Ruby version here and remove the old one cleanly, and whether the newer version would be suitable for Dradis?

[dradis@dradis ~] ruby -v ruby 2.2.2p95 (2015-04-13 revision 50295) [x86_64-linux] [dradis@dradis ~] gem install bundler
ERROR: Error installing bundler:
bundler requires Ruby version >= 2.3.0.
[dradis@dradis ~]$

Thanks

Hey bootleshacker. I went through the same problem as you. Have a look at Installation Issue
Hope this helps. I didn’t have any sucess with CentOS, but I got it to work with Kali.