Error Installing json 1.8.1 on Windows

When doing the intial install (or running the reset.bat script), it first gives me the message "No sudo in " and then lists my PATH. Then ig goes through the gems, gets to “installing json 1.8.1” and then I get a pop up from as.exe saying “The procedure entry point libiconv_set_relocation_prefix could not be located in the dynamic link library libiconv-2.dll”

I noted that the PATH statement contains proper entries for Dradis, the Devkit, and my ruby install directory (which I added manually)

Ideas?

I must confess it’s been a little while since I played with Dradis on Windows.

What version of Ruby are you running?

Did you have a look at this one?

https://github.com/oneclick/rubyinstaller/issues/129

One thing I would recommend is to avoid ruby 2.0 on windows and probably the x64 build (so stick with 1.9.3 and 32-bit) there’s several gems (nokogiri, redcloth) which have problems on 2.0/x64 and are tricky or impossible to work around…

That did it! I renamed the dll in my system32 directory and all installed and compiled perfectly.

Thanks for the help