Failed to build childprocess 1.0.1

I really tried to figure this out before posting, but alas, here I am. I am trying to install Dradis on Kali, and running into the following issue:

Fetching childprocess 1.0.1
Installing childprocess 1.0.1 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /var/lib/gems/2.5.0/gems/childprocess-1.0.1/ext
/usr/bin/ruby2.5 mkrf_conf.rb

current directory: /var/lib/gems/2.5.0/gems/childprocess-1.0.1/ext
/usr/bin/ruby2.5 -rrubygems /usr/share/rubygems-integration/all/gems/rake-12.3.3/exe/rake
RUBYARCHDIR=/var/lib/gems/2.5.0/extensions/x86_64-linux/2.5.0/childprocess-1.0.1
RUBYLIBDIR=/var/lib/gems/2.5.0/extensions/x86_64-linux/2.5.0/childprocess-1.0.1
/usr/bin/ruby2.5: No such file or directory -- /usr/share/rubygems-integration/all/gems/rake-12.3.3/exe/rake (LoadError)

rake failed, exit code 1

Gem files will remain installed in /var/lib/gems/2.5.0/gems/childprocess-1.0.1 for inspection.
Results logged to /var/lib/gems/2.5.0/extensions/x86_64-linux/2.5.0/childprocess-1.0.1/gem_make.out

An error occurred while installing childprocess (1.0.1), and Bundler cannot continue.
Make sure that `gem install childprocess -v '1.0.1' --source 'https://rubygems.org/'` succeeds before bundling.

In Gemfile:
  webdrivers was resolved to 4.1.1, which depends on
    selenium-webdriver was resolved to 3.142.3, which depends on
      childprocess

== Command ["bundle install"] failed ==

I installed all the dependencies, so I thought. Any suggestions/help?

Thank you very much.

@fujiyama17 are you using these installation instructions? https://dradisframework.com/ce/documentation/install_kali.html If so, can you confirm what commit your instance is on? This should do the trick:
git log | head -n 1

That is the guide I was using, and I received exactly the same error. This is on a freshly built Kali box. The commit I’m showing is: 767c36d1dfc5abbf46e4b488b1de8e2a591f485e.

I had a similar issue @fujiyama17 @jlacoss , Looks like I was missing rake from being installed. I ran gem install rake then reran in the install script and it appeared to work

1 Like

Thanks @alexrf11! @jlacoss can you give that a try?

It looks like that was the magic ticket! Thank you @rachkor and @alexrf11 !!

Same problem and rake install fixed it.