Ruby's Bundler gem

I’m trying to install the current version of Dradis. I followed these instructions:

$ git clone https://github.com/dradis/dradisframework.git
$ cd dradisframework/
$ ruby bin/setup
$ bundle exec rails server

when I run ruby /bin/setup I get the following error:

== Copying sample files ==
== Installing dependencies ==
Resolving dependencies…
The Gemfile’s dependencies are satisfied

== Preparing database ==
Bundler could not find compatible versions for gem “bundler”:
In Gemfile:
rails (= 4.1.9) ruby depends on
bundler (< 2.0, >= 1.3.0) ruby

Current Bundler version:
bundler (1.1.4)

This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running gem install bundler?

== Removing old logs and tempfiles ==

== Restarting application server ==

The frustrating part is that when I run “gem list” it shows I have bundler version 1.10.4

*** LOCAL GEMS ***

actionmailer (4.1.9)
actionpack (4.1.9)
actionview (4.1.9)
activemodel (4.1.9)
activerecord (4.1.9)
activesupport (4.1.9)
acts_as_tree (1.6.1)
addressable (2.3.6)
ansi (1.4.3)
arel (5.0.1.20140414130214)
atomic (1.1.16)
bcrypt (3.1.9)
bcrypt-ruby (3.0.1)
bootstrap-sass (2.3.2.2)
buftok (0.2.0)
builder (3.2.2)
bundler (1.10.4)

I’m not that familiar with Ruby and don’t know how to further troubleshoot this. Can someone please help me resolve this issue so that I can install Dradis?

  1. Is this in Kali? If if is there may be a conflict between the Bundler used by Kali (installed via apt-get) and the one found by Ruby (via Rubygems).

  2. Does this help?

$ gem install bundler --no-rdoc --no-ri

http://dradisframework.org/slides/bsides2015/#/6/3

Yes, this is in Kali. Can I force the use of the 1.10.4 version with Dradis and let everything else use package installed with apt-get? The command you provided made no change. I removed the package bunder package from apt and was able to complete the setup. If I re-install the package with apt, will it break Dradis? Thanks again for your help.

I just pushed 3.0.0.rc2 packages which should be a “uncompress and run” experience, if you want to check them out:

I downloaded the program, installed it, and ran it. Everything is working well dependency wise. I had 0 complications getting it up and going.

Excellent, thanks for sharing @Russel