Kali install problem


#1

When I install dradis on kali, after I put redis-server command… It show like this. What should I do to fix it??

10409:C 18 Dec 18:57:32.607 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
10409:M 18 Dec 18:57:32.608 * Increased maximum number of open files to 10032 (it was originally set to 1024).
10409:M 18 Dec 18:57:32.608 # Warning: 32 bit instance detected but no memory limit set. Setting 3 GB maxmemory limit with ‘noeviction’ policy now.
.
.-__ ''-._ _.- .. ‘’-._ Redis 3.2.3 (00000000/0) 32 bit
.-.-```. ```\/ _.,_ ''-._ ( ' , .-` | `, ) Running in standalone mode |`-._`-...-` __...-.-.|’_.-'| Port: 6379 |-. ._ / _.-' | PID: 10409-._ -._-./ .-’ .-’
|-._-.
-.__.-' _.-'_.-'| |-.
-._ _.-'_.-' | http://redis.io-._ -._-..-’.-’ .-’
|-._-.
-.__.-' _.-'_.-'| |-.
-._ _.-'_.-' |-._ -._-.
.-’_.-’ _.-’
-._-..-’ _.-’
-._ _.-'-.
.-’

10409:M 18 Dec 18:57:32.608 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
10409:M 18 Dec 18:57:32.608 # Server started, Redis version 3.2.3
10409:M 18 Dec 18:57:32.608 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
10409:M 18 Dec 18:57:32.608 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
10409:M 18 Dec 18:57:32.608 * DB loaded from disk: 0.000 seconds
10409:M 18 Dec 18:57:32.608 * The server is now ready to accept connections on port 6379


#2

@r37r0uv33, I’m Rachael with the Dradis support team. Thanks for sending this over! Does Dradis work as expected or are you running into errors when you upload files, etc?

The ending of the output suggests that the warnings are not causing any problems, just there for reference:

If you’re running into problems, have you tried changing the configurations mentioned in the warning messages? (e.g. “add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect”)